Strict Standards: Declaration of BB_Walker_Blank::start_lvl() should be compatible with BB_Walker::start_lvl($output) in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_lvl() should be compatible with BB_Walker::end_lvl($output) in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::start_el() should be compatible with BB_Walker::start_el($output) in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/classes.php on line 1127

Strict Standards: Declaration of BB_Walker_Blank::end_el() should be compatible with BB_Walker::end_el($output) in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/classes.php on line 1127

Strict Standards: Redefining already defined constructor for class bbdb in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/db-mysql.php on line 12
Login Problem « Support Forums

Support Forums » Installation
Installation

Login Problem

(14 posts)
  1. mico
    Member

    Hello,

    I am a newbie not an expert. I installed SynApp2 as directed in the synapp2.txt file, setup the database and the table, added a username and password to the table. I can see the login screen and when I press on login I get to a page where I enter my username and password but then I get an error saying : Unrecognized username and/or password

    I am stuck here and do not know what to do? Do I need to change anything in the access.php file?

    Any help is much appreciated.

    Thanks,

    Mico

    Posted 10 years ago #

  2. Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/kses.php on line 440

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/kses.php on line 510

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/kses.php on line 512
    richard


    Administrator

    Hi Mico,

    There are several things that could be issues with login.

    I'll assume:

    1. you're using MySQL and
    2. you've created a MySQL user named: 'synapp2' with all available privileges and with a password value of: 'password'

    and that:

    3. you've created the database - synapp2 - and
    4. you've created the table - users - and
    5. that you've been able to insert a record into synapp2.users with a username value of your choosing, and that
    6. the password value has been encrypted with the MySQL password function

    That's easy to do with a tool like phpMyAdmin.

    Have those steps been done?

    ////

    If you're using the MySQL command line, see the post about the encrypting the password field:
    http://www.synapp2.org/forum/topic.php?id=4

    BTW: If you don't have phpMyAdmin, I'd highly recommend you go get it. It's free and, in my opinion, a *must have* tool.

    ////

    If steps 1. and 2. are not done, then there are issues with the MySQL installation. That's got to get fixed first.

    ////

    If:

    a) you've been able to create a MySQL user named 'synapp2' and
    b) have assigned a password value of 'password' and
    c) you've created a database named 'synapp2' then
    d) you do not need to edit access.php

    ////

    We can see what's going on with the AJAX exchange sequence by adding a search string to the url in the browser address field: &show_response=1

    http://yourserver/synapp2/_shared_/login.htm?appid=synapp2&show_response=1

    and then make sure that you refresh/reload the page.

    ////

    With show_response turned on, we can see how authentication and authorization is working.

    If UNSUCCESSFUL you'll see something like:

    <debug_msg>auth_connect('localhost', 'synapp2') - attempt SUCCEEDED</debug_msg>
    <debug_msg>user validation FAILED against synapp2.users for username = 'foo' and Password = '*******'</debug_msg>

    If SUCCESSFUL you'll see something like:

    <debug_msg>auth_connect('localhost', 'synapp2') - attempt SUCCEEDED</debug_msg>
    <debug_msg>user validation SUCCEEDED against synapp2.users for username = 'guest' and Password = '*******'</debug_msg>
    <debug_msg>db_connect('localhost', 'synapp2') - attempt SUCCEEDED</debug_msg>
    <debug_msg>select_db('synapp2') - attempt SUCCEEDED</debug_msg>

    ////

    If you're still having trouble, please post the unsuccessful <debug_msg>'s related to authorization and validation, as shown above.

    We'll go from there.

    -- Richard

    Posted 10 years ago #
  3. mico
    Member

    Hi Richard,

    Thank you for your reply. The debug message is:

    </debug_msg>
    <debug_msg>auth_connect('localhost', 'synapp2') - attempt failed</debug_msg>
    </response>

    apparently the application did connect to the database. I found that Cpanel in my host add the prefix "postweb_" to my database name. It also add the same prefix to the username. However, the username can be called witout the prefix.

    What shall I do to get the application to call the database name with the added prefix?

    Posted 10 years ago #

  4. Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/kses.php on line 440

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/kses.php on line 510

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /webroot/s/2/s2admin/synapp2.org/www/forum/bb-includes/kses.php on line 512
    richard

    Administrator

    Use of a site prefix does require editing of access.php.

    Look at the function get_site_prefix() in access.php.

    You can add an entry to the prefix map: $map_prefix['www.yoursite.com'] = 'postweb_';

    The value for the index key should be whatever is returned by strtolower($_SERVER['HTTP_HOST']).

    For now, you could even go with:

    $map_prefix[strtolower($_SERVER['HTTP_HOST'])] = 'postweb_';

    SynApp2 (access.php) will automatically add the site prefix to the user name, so you'll have both a username and database named 'postweb_synapp2'.

    To keep things simple, again - just for now, use CPanel set the password for user 'postweb_synapp2' to be 'password'.

    I'm in the process of changing how access.php gets customized, by moving some elements into a separate directory and a configuration file. That should show up in the next release.

    Also make sure that:

    a) you have write access to the SynApp2 installation directory and all directories below
    b) PHP safe mode is OFF
    c) you have at cookies enabled in your browser (you can do that for just your server)

    Thanks Mico.

    Let me know how it goes.

    -- Richard

    Posted 10 years ago #
  5. mico
    Member

    Hi Richard,

    I add the line

    $map_prefix[strtolower($_SERVER['HTTP_HOST'])] = 'postweb_';

    to access.php as you said. Know I can login and get the start page. but when I click on KeyMap and type in the name of my database I can not connect to it (nothing happens on the page). I tried all different name combinations "postweb_databaseName", "_databaseName" and "databaseName" but nothing is making any difference I still can not connect to any of my databases?

    Help please ....

    Thanks,

    Mico

    Posted 10 years ago #

RSS feed for this topic

Reply »
»

You must log in to post.